You are not logged in.

Announcement

This forum has been replaced by community.chakralinux.org. No new registrations, topics, or replies can be made here. Read this for more information.

#1 2016-08-05 20:19:42

AlmAck
Sr. Packager
From: Switzerland
Registered: 2012-01-20
Posts: 447
Website

KDE Applications 16.08

Hi All,
I just uploaded today the next KDE Applications series, 16.07.80 (Beta1), to the [kde-unstable] repository. I'm currently building the RC1 that will land tomorrow to the same repository. If you want to test this new packages please enable both [testing] and [kde-unstable].
Other then that, I updated the ruby pkg too, from version 2.2.x to 2.3.x.
I strongly suggest to run the script "chakra-check-links" and verify that there aren't any packages that link to the old ruby library, in case report here.

What's new:
libkdepim was removed and splitted in:
* akonadi-contacts
* akonadi-mime
* akonadi-notes
To avoid orphan packages I added the pkg "kio-pim" to kdepim-runtime as replacement, so that during the upgrade the conflicts are properly handled.

Pkgs removed upstream (we will remove them when we move the apps 16.08 to stable). No replacement are foreseen for now, we can discuss if and how to handle a smooth and automatic removal of this packages.
* kdegraphics-strigi-analyzer
* kdenetwork-strigi-analyzers
* kdepimlibs
* kdesdk-strigi-analyzers
* libkdeedu
* mplayerthumbs

New packages ported to KF5:
* kolourpaint (replaces kdegraphics-kolourpaint)
* cervisia (replaces kdesdk-cervisia)
* kdf (replaces kdeutils-kdf)

https://community.kde.org/Applications/ … ease_Notes

Offline

#2 2016-08-07 22:52:05

tetris4
Communicator
From: NL, CY
Registered: 2009-12-11
Posts: 5,253
Website

Re: KDE Applications 16.08

AlmAck wrote:

Pkgs removed upstream (we will remove them when we move the apps 16.08 to stable). No replacement are foreseen for now, we can discuss if and how to handle a smooth and automatic removal of this packages.
* kdegraphics-strigi-analyzer
* kdenetwork-strigi-analyzers
* kdepimlibs
* kdesdk-strigi-analyzers
* libkdeedu
* mplayerthumbs

Great work AlmAck, thanks!

I think all these packages can be safely removed, since nothing else seems to depends on them.

Only kdepimlibs4 will have to remain as other packages appear to need it.

Offline

Board footer

Powered by FluxBB